Changes between Version 5 and Version 6 of WikiStart/Ruby/Ruby1.9


Ignore:
Timestamp:
05/03/12 17:05:32 (7 years ago)
Author:
Alexander.Duda
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • WikiStart/Ruby/Ruby1.9

    v5 v6  
    22 
    33'''Note''' Debian is calling its Ruby binaries and packages ruby1.9.1, but it is NOT a ruby 1.9.1 version. Call ruby1.9.1 --version to have the actual version number. 
     4 
     5'''Note''' The only Flavor which supports ruby 1.9.x is at the moment master! 
    46 
    57Ruby 1.8.7 is officially reaching its end of life (it is going to be maintained until mid-2013, but no major developments are going to happen on it). Ruby 1.9 is very stable and has very little incompatibilities with 1.8 code (backward compatibility is a bit more tricky, though). Rock will maintain backward compatibility with 1.8 until at least the end of 2012 
     
    1012 
    1113Ruby 1.9.3 has some issues (#134). The next version of autoproj is going to fix these. 
     14 - ruby is using psych which is a lot more strict (you have to update your yaml files) 
    1215 
    1316== Howto ==