Changes between Initial Version and Version 1 of WikiStart/Ruby/SciencePackages


Ignore:
Timestamp:
04/08/11 17:48:59 (9 years ago)
Author:
sylvain.joyeux
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • WikiStart/Ruby/SciencePackages

    v1 v1  
     1= NArray and Ruby/GSL = 
     2 
     3NArray is a fast array / matrix / vector library, Ruby/GSL is a wrapper on top of the GNU Scientific Library. They are listed in the same category as there are bridges between the two (i.e. convertion between NArray matrices/vectors and Ruby/GSL matrices/vectors) 
     4 
     5  * debian/ubuntu package: libnarray-ruby1.8 or libnarray-ruby1.9.1 (depending on your ruby version) 
     6  * documentation http://narray.rubyforge.org/ 
     7 
     8  * debian/ubuntu package: libgsl-ruby1.8 or libgsl-ruby1.9.1 (depending on your ruby version) 
     9  * documentation http://rb-gsl.rubyforge.org/ 
     10 
     11= Plotting = 
     12 
     13We usually use rgnuplot (the gnuplot gem) 
     14 
     15= Basic Eigen wrappers = 
     16 
     17Provided by the base/types_ruby package 
     18 
     19Provide only Eigen::Vector3 and Eigen::Quaternion, and operations between them 
     20 
     21The C++ types base::Vector3 and base::Quaterniond are represented using these classes on the Ruby side