Changes between Version 4 and Version 5 of WikiStart/Ruby/Ruby1.9


Ignore:
Timestamp:
04/30/12 17:25:29 (8 years ago)
Author:
sylvain.joyeux
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • WikiStart/Ruby/Ruby1.9

    v4 v5  
    11This page explains how to run Rock on Ruby 1.9.x. 
     2 
     3'''Note''' Debian is calling its Ruby binaries and packages ruby1.9.1, but it is NOT a ruby 1.9.1 version. Call ruby1.9.1 --version to have the actual version number. 
    24 
    35Ruby 1.8.7 is officially reaching its end of life (it is going to be maintained until mid-2013, but no major developments are going to happen on it). Ruby 1.9 is very stable and has very little incompatibilities with 1.8 code (backward compatibility is a bit more tricky, though). Rock will maintain backward compatibility with 1.8 until at least the end of 2012