Changes between Version 1 and Version 2 of WikiStart/Troubleshooting/CustomBoostVersion


Ignore:
Timestamp:
09/11/12 17:58:42 (7 years ago)
Author:
thro02
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • WikiStart/Troubleshooting/CustomBoostVersion

    v1 v2  
    11== Installation of boost == 
     2You can you the attached script in order to install boost.  
     3Copy into autoproj/scripts/ (or adapt the reference below) and copy the section below into your autoproj/init.rb  
     4 
     5{{{ 
     6# Check on default location to install boost 
     7#  
     8# boostversion = system(locate boost/version.hpp | xargs grep "#define BOOST_LIB_VERSION" | cut -d\" -f2 
     9begin 
     10        require File.join(File.dirname(__FILE__),"scripts/boost_installer.rb") 
     11        # The minimum boost version is a hard requirement - if its not fulfilled 
     12        # the newest boost version will be installed 
     13        bi = BoostInstaller.new('1.44.0') 
     14        newest_version_path = bi.install("/opt/boost") 
     15        env_set "BOOST_ROOT", newest_version_path 
     16        env_add "LD_LIBRARY_PATH", "#{File.join(newest_version_path,"lib")}" 
     17rescue 
     18        print "Could not install boost\n" 
     19end 
     20 
     21}}}